Critical netmask networking bug impacts thousands of applications

If you, or someone in your supply chain, uses npm in your app, put this update in your to-do list…: …:

Popular npm component netmask has a critical networking vulnerability, CVE-2021-28918. netmask is frequently used by hundreds of thousands of applications to parse IPv4 addresses and CIDR blocks or compare them. The component gets over 3 million weekly downloads, and as of today, has scored over 238 million total downloads. […]

Original Article